[Homeroast] Behmor drum suddenly not rotating

John Nanci john at chocolatealchemy.com
Wed Apr 13 13:28:04 CDT 2016


If the motor is working (how do you know?) then it sounds like the 
coupling has become detached from the shaft.  It is 'just' a matter for 
reattaching it.  Probably the screw and nut come out. No spare parts needed.

John

On 4/13/2016 9:02 AM, Claus Thøgersen wrote:
> Hi,
>
> This morning I started a roast with my more than 6 year old Behmor roaster. It had woasted fine last evening.
> Everything sounded ok, however maybe 8 to 10 years into the roast it started to smell very burnt.
> It turned out that the drum did not rotate but everything else is working ok. The motor works, but the drum is not rotating.
> Since I live in Denmark spare parts will have to be imported from the  US, and I will have to find a person that can change the motor if this is the solution.
> With a more than 6 year old roaster I am concerned about the life of the rest of the roaster. Unfortunately there are few alternatives for the Behmor available in Europe currently. I do not know if Behmor is going to get the EU certification for the new model that they are going to release soon, but I hope so.
>
> claus
> _______________________________________________
> Homeroast mailing list
> Homeroast at lists.sweetmariascoffee.com
> http://lists.sweetmariascoffee.com/mailman/listinfo/homeroast_lists.sweetmariascoffee.com
> <a href="http://www.sweetmariascoffee.com/forum/">Sweet Maria's Forum</a>
> <a href="http://www.sweetmarias.com/library">Our new Coffee Library</a>
>


---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus




More information about the Homeroast mailing list