[Homeroast] Quickmill Andreja Premium on the fritz...

Larry Dorman ldorman at gmail.com
Sun Apr 3 14:57:21 CDT 2016


It's a long and difficult to tell story, but I'll give it my best shot.  :)

Bought it in March 2012.  It was on hard water until ~Feb 2015.  It stays
on 24x7 roughly 345 days a year.  I only turn it off if I'm going to be
away from home for several days in a row.  I've always done my own
maintenance.  In addition to standard maintenance such as replacing the
group head gasket and deep cleanings, I've also:

1)  thoroughly cleaned the gicleur  - it wasn't horrendous, but it did have
some buildup from the hard water
2)  disassembled and thoroughly cleaned the cam lever assembly / gasket as
I was getting a little bit of leaking around it
3)  cleaned the fill probe
4)  replaced the vacuum breaker valve


I cleaned the fill probe because it seemed like the boiler wasn't always
getting refilled when it should.  That seemed to have taken care of the
problem at the time.  I replaced the vacuum breaker because it seemed like
I was ending up with a lot of water ending up in the drip tray even when
the machine wasn't in use.  In retrospect, I'm not sure that actually
needed to happen, but I have no reason to believe it did any harm, either.
There was some corrosion/buildup on the old vacuum breaker, but nothing
scary.

About a year ago, the reservoir low water warning started sounding
non-stop.  I did lots of troubleshooting to try to diagnose and resolve the
cause as it wasn't actually low water.  I cleaned and reset the magnetic
floats.  I made sure the tank was seating solidly against the stainless
steel panel where the sensors reside.  Nothing I did would make the alarm
stop so I set the jumper that disables the alarm and have simply taken
extreme care to not run out of water since.

Roughly six months ago the machine started exhibiting a new bad behavior
that has now gotten severe.   I turned the machine off for a trip.  When I
returned from the trip I turned it back on and went to bed expecting to
make drinks in the morning.  That morning I found that the machine was
cold.  I was worried that the element had gone out.  However, I turned it
off and back on a couple times and then it started filling the boiler and
the element kicked on and everything was fine.  There is no reason the
boiler wouldn't have been full, however, as it was turned off full and
there wouldn't have been much if any evaporation from a cold, closed
boiler.  The next time I went through this process it was the same... turn
it off/on a few times, let it pretend to fill the boiler, heat kicks on,
and all is good as long as I don't ever turn it off.

I just got back from a trip this week and went through the same process.  I
got the machine back 'online' like before and after it was ready I made a
couple drinks and left it on for the night.  The next morning I went to
make drinks.  The first thing I noticed was that there was water all over
the counter that had come from the machine.  After cleaning up the mess I
lifted the lever to do a cooling shot, and the pump wouldn't engage at
all.  After fiddling with it for a while (power cycles, lever on/off, etc.)
I gave up, turned it off, and left it off for the day.  Yesterday, now
thoroughly in need of a fix, I tried the power cycles again and got the
pump to engage.  It was acting like it was filling the boiler, but the
water level in the reservoir never went down.  Instead, it was just
returning everything it was pumping back to the reservoir.  I noticed the
group head pressure was also climbing just as if I were doing a back-flush.
Moving the lever half way so that the group head was open, but the contact
switch not closed allowed the water to drain to the drip tray through the
group head and relieved the pressure.

Other observations / notes:

*  During the power cycles (turning the power switch to off and back to
'II' (although it behaves the same at 'I'), sometimes it would do nothing,
sometimes it would engage the pump, sometimes it would emit a very brief
chirp and then do nothing or engage the pump.

*  At one point when it was doing its continuous fill efforts it actually
did start feeding water to the boiler.  It got so full that water shot from
a relief valve of some kind that is right in the middle of the top of the
boiler.  I'm guessing a similar thing happened in the middle of the night
when I had filled the boiler, left it on, and found water all over the
counter in the morning.

* I removed the fill probe again last night and checked that it isn't
corroded.  It looks really clean with no obvious reasons it shouldn't be
functioning.

* While the fill probe was removed I also removed the vacuum breaker.  This
allowed me to shine a light into the boiler and visually see that the
boiler was nearly full and that the boiler isn't just a big corroded mess.

* Today I was able to fiddle with it enough that I got the element to come
back on and function well enough to make a couple drinks.  This tells me
that the element is still functional.  However, it did not ever engage the
pump to refill the boiler so I've turned it back off to cool so I can do
more troubleshooting.

*  During some of the troubleshooting I hit a point where it seemed like
the pump was behaving as if it were weak and at one point as if it were
seized.  I'm thinking there may be some old deposits that have broken loose
at this point and jacking with the pump.


Final thoughts:

It seems like there are multiple problems I'm facing and not just one
simple problem.  The reservoir water level alarm really should just work.
That it doesn't work suggests to me that maybe one of the sensors is no
longer working or its signal isn't being processed appropriately.

I wonder if the pump has some gunk in it that has started to impact it in
some way.  The pump worked fine today, so it may have finally passed
whatever it was chewing on.

It's back to a place where the system doesn't seem to know when the boiler
does and doesn't need filled.


So... who wants a challenge?


More information about the Homeroast mailing list