[Homeroast] Thermostat issue?

Hank Arnold hankarnold at gmail.com
Wed Oct 14 08:52:28 CDT 2015


>
> John unfortunately it's been like this from Day 1....I clean the machine
> before every use since I often go FC+ and higher on many roasts....and
> frankly wouldn't want to give the machine up for a period of time to send
> it back for repair.  So I guess I can live with the inconcenience.
>

Hank



>
> Hank,
>
> Sounds like you have a thermistor aging or something like.  Granted you
> often need perfect conditions to nail 1 lb, 12 oz it can do day in day
> out.  Maybe look into contacted Behmor tech support.
>
> On 10/12/2015 2:16 PM, Hank Arnold wrote:
> > Is it the newer models that have the Dead mans switch?  I wouldn't much
> > like that, although I guess it's not any different than what I do now.  I
> > just wish the roaster was more efficient....I can only do a 1/2 pound of
> > beans on the 1 pound setting to get them anymore roasted than a light
> City+
> > at the darkest...so many of mine are done at 6 oz on the pound setting.
> >
> > Hank
> > _______________________________________________
> > Homeroast mailing list
> > Homeroast at lists.sweetmariascoffee.com
> >
> http://lists.sweetmariascoffee.com/mailman/listinfo/homeroast_lists.sweetmariascoffee.com
> > <a href="http://www.sweetmariascoffee.com/forum/">Sweet Maria's
> Forum</a>
> > <a href="http://www.sweetmarias.com/library">Our new Coffee Library</a>
> >
>
>
> ---
>
>
>
>
> ---------------


More information about the Homeroast mailing list