[Homeroast] Electrical question on coffee brewers

Alchemist John john at chocolatealchemy.com
Thu Oct 7 07:45:10 CDT 2010


I'm with Mike here.  There are just too many 
other factors that affect the delivered water 
temperature.  If it is configured as most brewers 
out there, it is heating the water to boiling, 
then 'shooting' it through the cold water 
chamber, cooling it to 195-205.  Overall, I would 
say it has nothing to do with electrical so much as design and thermostat.

At 10:59 PM 10/6/2010, you wrote:
>All electrical theory aside, heating the water to a specified temperature is
>not the same thing as dispensing the same water temperature to the grinds so
>likely not defective or technically false advertising. For example one might
>PID a Silvia brew boiler, but an offset must be set to compensate for the
>lower temperature at the group. The PID then "displays" the brew temp, not
>the actual higher boiler temp. Same principle for a dripper, there will be
>heat loss from the maximum heated water temp...
>
>Slave to the Bean  miKe mcKoffee
>www.CompassCoffeeRoasting.com
>URL to Rosto mods, FrankenFormer, some recipes etc:
>http://www.mckoffee.com/
>
>Ultimately the quest for Koffee Nirvana is a solitary path. To know I must
>first not know. And in knowing know I know not. Each Personal enlightenment
>found exploring the many divergent foot steps of Those who have gone before.
>
>Sweet Maria's List - Searchable Archives
>http://themeyers.org/HomeRoast/
>
>
> > -----Original Message-----
> > From: homeroast-bounces at lists.sweetmariascoffee.com
> > [mailto:homeroast-bounces at lists.sweetmariascoffee.com] On
> > Behalf Of Dennis Guyer
> > Sent: Tuesday, October 05, 2010 11:18 AM
> > To: SweetMarias
> > Subject: [Homeroast] Electrical question on coffee brewers
> >
> > I hope I can explain my situation properly.  I have a drip
> > coffee brewer that is advertised and being able to heat the
> > water to 195° - 205°.  It is also listed as using 1400 watts.
> >  Using my Kill a Watt meter, it reads somewhere between 1200
> > and 1250 watts draw.  My line voltage is usually 118v to 120v
> > dropping it around 116v during the brewing process.  The
> > water using a K-Probe is reading 185° for most of the cycle
> > ending at a high of 193°.  My question is - is the brewer
> > defective?  Is the line voltage determining the low readings?
> >  Do I take the brewer back and demand my money back or is
> > this to be expected?
> >
> >
> >
> > Dennis
>
>
>_______________________________________________
>Homeroast mailing list
>Homeroast at host.sweetmariascoffee.com
>http://host.sweetmariascoffee.com/mailman/listinfo/homeroast_lists.sweetmariascoffee.com
>Homeroast community pictures -upload yours!) : 
>http://www.sweetmariascoffee.com/gallery/main.php?g2_itemId=7820




More information about the Homeroast mailing list